Issues Signing In

Incident Report for Benchmark Universe

Resolved

This incident has been resolved.
Posted May 19, 2026 - 14:47 UTC

Monitoring

We have deployed a fix and are monitoring the issue.
Posted May 19, 2026 - 14:30 UTC

Investigating

Some customers may be experiencing slowness logging in to Benchmark Universe. We’re aware of the issue and are working on it urgently.

We’re very sorry for the inconvenience.
Posted May 19, 2026 - 13:57 UTC
This incident affected: Benchmark Universe (Sign In/Login Page).