Slowness Accessing BU and Its Resources

Incident Report for Benchmark Universe

Resolved

This incident has been resolved.
Posted Sep 18, 2026 - 14:06 UTC

Investigating

Some customers may be experiencing slowness logging in to Benchmark Universe, or when accessing resources or assignments. We’re aware of the issue and are working on it urgently.

We’re very sorry for the inconvenience. Please know our teams are working hard to get everything up and running more smoothly.
Posted Sep 18, 2026 - 13:44 UTC
This incident affected: Benchmark Universe (Sign In/Login Page).